SQL Delta Logo
SQL Delta Banner

Error running SQL Delta from Command Line

Error running SQL Delta from Command Line

Postby shah_117 » Thu Jan 04, 2007 7:51 pm

Hi there,

I am a registered user of SQL Delta V4. I recently downloaded the SQL Delta Work and tried to create a project to basically create a snapshot of a database and e-mail it to the IT department. I planned on creating a scheduled task to run every night and process the database. But when I run the .sdp file through SQL Delta from the command line (i.e. C:\SQLDeltaV4.exe Dev_Snp.sdp), I get an error in the CommandLineErrors.txt file. The details of the error are as follows:


1/4/2007 11:42:56 AM - Error creating structure details


Access violation at address 0073D43C in module 'SQLDeltaV4.exe'. Read of address 00000000

When I try opening the same SDP file from the SQLDelta GUI, and then create a snapshot, everything works fine. I dont know what is causing the command line method to fail. Please advise.
Posts: 6
Joined: Fri Sep 22, 2006 1:55 pm

Postby GWA » Tue Feb 20, 2007 9:57 am

I have exactly the same problem. And i have also compare the two databases in SQLDelta. It works. So?


2/20/2007 10:43:10 AM - An unexpected internal system error has occured.


Access violation at address 0058D879 in module 'SQLDeltaV4.exe'. Read of address 00000000

Can someone help me please.
Posts: 1
Joined: Tue Feb 20, 2007 9:52 am

Postby Jay Bailey » Wed Feb 21, 2007 12:58 am


We now have a log command added to the command line, can you please use the Check for Updates Wizard to install the latest version of SQL Delta.

To get the log function to work you need to add the <LogFile> property to your project as in this example


Can you add this and then try and run your command line project again, then email the log file along with your project file to support@sqldelta.com.
Jay Bailey
SQL Delta Support
Jay Bailey
Site Admin
Posts: 204
Joined: Tue Aug 03, 2004 4:57 am

Return to SQL Delta Workbench